deco - 502 (bad gateway) from deno deploy infrastructure – Incident details

502 (bad gateway) from deno deploy infrastructure

Resolved
Degraded performance
Started about 1 month agoLasted about 3 hours

Affected

hosting-denodeploy

Degraded performance from 11:40 AM to 12:48 PM, Under maintenance from 12:48 PM to 2:30 PM

Updates
  • Resolved
    Resolved

    Deno deploy isolates were killed due to memory starvation.

    A new memory profile was applied, thus resolving this issue.

  • Update
    Update

    Deno deploy added capacity to mitigate reported issues.

    Still investigating root cause.

    We are back to normal status rate.

  • Investigating
    Investigating
    We are currently investigating this incident.