deco - 3rd party dependency service with limited capabilities – Incident details

3rd party dependency service with limited capabilities

Resolved
Degraded performance
Started 2 months agoLasted about 1 hour

Affected

admin

Degraded performance from 6:31 PM to 7:57 PM

Updates
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    esm.sh is a code dependency service (similar to NPM) that multiple deco sites use to fetch dependencies.

    It's experiencing a partial downtime, limiting the capacity for new deploys.

    We are continuing to work on a bypass solution for this incident.

    This doesn't affect current running sites.