deco - Intermittent slowness and failures loading sites – Incident details

Third Party: Supabase → Storage experiencing partial outage

Intermittent slowness and failures loading sites

Resolved
Partial outage 50 %
Started 20 days agoLasted 15 minutes

Affected

hosting-kubernetes

Partial outage from 10:55 AM to 11:10 AM

Updates
  • Resolved
    UTC
    Resolved

    Between approximately 10:55 and 11:10 UTC — about 15 minutes — a DNS resolution issue at our cloud infrastructure provider temporarily affected the loading of most sites. A portion of requests experienced slowness or failed to load during this window.


    Service recovered around 11:10 UTC and all sites are operating normally. The cause was external and limited in duration, and no action is required from customers.


    We continue to monitor with the provider to ensure stability and mitigate any recurrence.

  • Identified
    UTC
    Identified

    We have identified that the disruption was caused by a brief DNS resolution issue at our cloud infrastructure provider, which temporarily affected the loading of most hosted sites.


    The cause is external to the deco infrastructure. We are already seeing signs of recovery and the service is returning to normal. We continue to monitor closely until full confirmation.

  • Investigating
    UTC
    Investigating

    We are investigating reports of intermittent slowness and failures loading sites hosted on the platform, beginning around 10:55 UTC

    Our team is actively working to identify the source and restore normal operation. We will post further updates as we make progress.